summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..17f3b69
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(lispgamejam, 0.1.0)
+AC_CONFIG_SRCDIR(gamejam)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([2.2 2.0])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([sly])
+
+AC_OUTPUT