summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-04-30 08:46:33 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-04-30 08:46:33 -0400
commitf98b1e35944dde31250fa758be88adbc0619b3b0 (patch)
tree569dbaeafdab9ec69bafb5e8e36c88ff6ca1b3b9 /configure.ac
parent22203e6d1041dff644199a41d5299de9b44ee67a (diff)
Add project base code and assets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..17f3b69
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(lispgamejam, 0.1.0)
+AC_CONFIG_SRCDIR(gamejam)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([2.2 2.0])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([sly])
+
+AC_OUTPUT