summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2022-02-06 12:16:52 -0500
committerDavid Thompson <dthompson2@worcester.edu>2022-02-06 12:16:52 -0500
commitab0b722b0719e3370a21359e4d511af9c4f14e60 (patch)
tree5f98f6cb1551b2711d2336ad4317af055c9488fa /Makefile.am
parent3e406cbef274ad83c44674a8ee404684eb16bdbe (diff)
Do not compile or load inotify module when inotify is not available.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e3eb96f..1bddaa4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,6 @@ bin_SCRIPTS = \
SOURCES = \
haunt/config.scm \
haunt/utils.scm \
- haunt/inotify.scm \
haunt/post.scm \
haunt/page.scm \
haunt/asset.scm \
@@ -81,6 +80,12 @@ SOURCES += \
endif
+if HAVE_INOTIFY
+
+SOURCES += haunt/inotify.scm
+
+endif
+
TESTS = \
tests/helper.scm \
tests/post.scm \