summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2021-10-01 08:19:52 -0400
committerDavid Thompson <dthompson2@worcester.edu>2021-10-01 08:41:27 -0400
commit1ef0c9b18263ee1354987e8f104aff562a953fe6 (patch)
tree2085b254b3871e08399d33ad6a43fab42d82a9e5 /Makefile.am
parent602569cd13f8f018194f54f39f4645d36d5b3821 (diff)
Add (chickadee data quadtree) module.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9a108d5..6bcc25a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,7 @@ SOURCES = \
chickadee/data/heap.scm \
chickadee/data/array-list.scm \
chickadee/data/queue.scm \
+ chickadee/data/quadtree.scm \
chickadee/data/grid.scm \
chickadee/data/path-finding.scm \
chickadee/math.scm \
@@ -99,7 +100,8 @@ SOURCES = \
chickadee/cli/bundle.scm
TESTS = \
- tests/math/vector.scm
+ tests/math/vector.scm \
+ tests/data/quadtree.scm
TEST_EXTENSIONS = .scm
SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)