summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2023-09-22 08:24:42 -0400
committerDavid Thompson <dthompson2@worcester.edu>2023-09-23 16:29:08 -0400
commitea0d3009fa7020d75c1657cb532570305de699a6 (patch)
tree288c154ad995c78115eeb85140dff2703fad3f50 /configure.ac
parent00df702b030ee01d6c544cb7e3e1170b7f29a343 (diff)
Allow game to be properly installable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb264af..779d240 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl -*- Autoconf -*-
+# -*- Autoconf -*-
AC_INIT(super-bloom, 0.1.0)
AC_CONFIG_SRCDIR(super-bloom)
@@ -8,6 +8,9 @@ AM_SILENT_RULES([yes])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+#AC_CONFIG_FILES([super-bloom/config.scm])
+
+AC_PROG_SED
GUILE_PKG([3.0])
GUILE_PROGS
@@ -15,4 +18,10 @@ GUILE_PROGS
GUILE_MODULE_REQUIRED([chickadee])
GUILE_MODULE_REQUIRED([catbird])
+# Installation directories for .scm and .go files.
+guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
+guileobjectdir="${libdir}/guile/$GUILE_EFFECTIVE_VERSION/site-ccache"
+AC_SUBST([guilemoduledir])
+AC_SUBST([guileobjectdir])
+
AC_OUTPUT