summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2021-04-16 17:44:49 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2021-04-16 17:44:59 -0400
commit8de38cdc53b8bc1ce7d6e5bca1b00ada93e0f967 (patch)
tree22d7723206de00362b28636be959a8585d36439e /configure.ac
Add project scaffolding.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..582cdb7
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(spring-lisp-game-jam-2021, 0.1.0)
+AC_CONFIG_SRCDIR(lisp-game-jam)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([3.0 2.2])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([starling node])
+
+AC_OUTPUT