summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-12-22 14:35:44 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-22 16:28:18 -0500
commit8b9b5d371d1dc1c780e227ce9a555cf6c88a85c8 (patch)
treef1b6524f92aaa329667f08f4a010a7b5e6925ae8 /configure.ac
parent60d601cbb5eb142d01f880b5902329ada93fc91a (diff)
Upgrade to SDL2!
This commit is massive and crazy and I'm not going to do the usual GNU ChangeLog thing because it's just too much. Let's just be happy that the port is completed!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 4 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 7708392..a31480a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,39 +19,12 @@ sly_datadir="`eval eval echo $datadir | sed -e "s|NONE|$sly_prefix|g"`"
AC_SUBST([sly_datadir])
GUILE_PROGS([2.0.11])
-GUILE_MODULE_REQUIRED([sdl sdl])
-GUILE_MODULE_REQUIRED([sdl mixer])
-GUILE_MODULE_REQUIRED([sdl ttf])
+GUILE_MODULE_REQUIRED([sdl2])
+GUILE_MODULE_REQUIRED([sdl2 image])
+GUILE_MODULE_REQUIRED([sdl2 mixer])
+GUILE_MODULE_REQUIRED([sdl2 ttf])
GUILE_MODULE_REQUIRED([gl])
-dnl Freeimage doesn't have a pkg-config file, so use this primitive
-dnl test instead.
-AC_CHECK_LIB([freeimage], [FreeImage_GetVersion],,
- [AC_MSG_ERROR([freeimage not found.])])
-
-LIBFREEIMAGE="libfreeimage"
-LIBFREEIMAGE_LIBDIR="no"
-LIBFREEIMAGE_PREFIX="no"
-
-AC_ARG_WITH([libfreeimage-prefix],
- [AS_HELP_STRING([--with-libfreeimage-prefix=DIR], [search for FreeImage in DIR])],
- [case "$withval" in
- yes|no)
- ;;
- *)
- LIBFREEIMAGE="$withval/lib/libfreeimage"
- LIBFREEIMAGE_PREFIX="$withval"
- LIBFREEIMAGE_LIBDIR="$withval/lib"
- ;;
- esac])
-
-dnl Library name suitable for `dynamic-link'.
-AC_MSG_CHECKING([for libfreeimage shared library name])
-AC_MSG_RESULT([$LIBFREEIMAGE])
-AC_SUBST([LIBFREEIMAGE])
-AC_SUBST([LIBFREEIMAGE_PREFIX])
-AC_SUBST([LIBFREEIMAGE_LIBDIR])
-
LIBGSLCBLAS="libgslcblas"
LIBGSLCBLAS_LIBDIR="no"
LIBGSLCBLAS_PREFIX="no"