summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-11-07 21:11:12 -0500
committerDavid Thompson <dthompson2@worcester.edu>2014-11-07 21:11:12 -0500
commit7bbcf5dacd1e392a1857c58ca17753a334e75a12 (patch)
treeaa23dcc2d9f79096c530fd1fc9f89ff046067502 /configure.ac
parenteaa2189f189eedce4c10fd0fe56af563ffc00cc5 (diff)
configure: Check for freeimage.
* configure.ac: Perform a primitive check for libfreeimage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e23db07..489e0e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,8 +16,11 @@ GUILE_MODULE_REQUIRED([sdl mixer])
GUILE_MODULE_REQUIRED([sdl ttf])
GUILE_MODULE_REQUIRED([gl])
+dnl Freeimage doesn't have a pkg-config file, so use this primitive
+dnl test instead.
+AC_CHECK_LIB([freeimage], [FreeImage_GetVersion],,
+ [AC_MSG_ERROR([freeimage not found.])])
+
PKG_CHECK_MODULES([GSL], [gsl])
-# Why doesn't freeimage have a pkg-config file?
-#PKG_CHECK_MODULES([freeimage], [freeimage >= 3.0])
AC_OUTPUT