summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPieter Slabbert <blob626@gmail.com>2013-08-23 06:54:04 +0200
committerPieter Slabbert <blob626@gmail.com>2013-08-23 06:54:04 +0200
commitb0a806a285013bc932ec86014bbdcc9f0b11235d (patch)
tree9c0f0227fd51f069851f01e8fa32a610e538c97d /Makefile.am
parent2c2cc052124b4709075132430e9b67ed49d0f76e (diff)
add wildcards to makefile for sources
Makefile.am didn't change as modules were added added wildcards so that all the files in 2d/ are used as sources
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 19f9992..031ffd6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,17 +3,6 @@ include guile.am
moddir=$(prefix)/share/guile/site/2.0
godir=$(libdir)/guile/2.0/ccache
-SOURCES = \
- 2d/agenda.scm\
- 2d/animation.scm\
- 2d/coroutine.scm\
- 2d/game-loop.scm\
- 2d/gl.scm\
- 2d/helpers.scm\
- 2d/math.scm\
- 2d/sprite.scm\
- 2d/texture.scm\
- 2d/vector.scm\
- 2d/window.scm
+SOURCES = $(wildcard 2d/*.scm 2d/*/*.scm)
EXTRA_DIST += env.in