summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-17 22:27:26 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-17 22:27:26 -0400
commit288969b63fa8492f741fe89ba194920b5efd0400 (patch)
tree4278439f4a53179535a50f04de7ac1f01085f1b5 /configure.ac
parent9b3a17e3817fb47b1414aa0480948cbbcc03ca16 (diff)
Add X clipboard support.
* configure.ac (XCLIP): New variable. * package.scm: Add xclip dependency. * shroud/config.scm: Untrack. Now automatically generated. * shroud/config.scm.in: New file. * shroud/utils.scm (call-with-clipboard): New procedure. * shroud/ui/show.scm (%options): Add --clipboard option. (show-help): Add help text for --clipboard. (display-secret): New procedure. (shroud-show): Handle --clipboard option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b6de58..3ddbac9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,10 @@ AM_SILENT_RULES([yes])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
AC_CONFIG_FILES([scripts/shroud], [chmod +x scripts/shroud])
+AC_CONFIG_FILES([shroud/config.scm])
GUILE_PROGS([2.0.11])
+AC_PATH_PROG([XCLIP], [xclip])
+
AC_OUTPUT