summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2020-04-10 08:55:50 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2020-04-10 08:55:50 -0400
commit2c5b19226815a406c60cc1a49c59864922364c55 (patch)
tree29348c110eb8cac36adfe20abfcfe3042e06c4d4 /configure.ac
parent781ab757856f95b3dd8c2ad573589912d8093464 (diff)
Add project skeleton and import engine code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..fbf713a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(lisparuga, 0.1.0)
+AC_CONFIG_SRCDIR(lisparuga)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([3.0 2.2])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([chickadee])
+GUILE_MODULE_REQUIRED([sdl2])
+
+AC_OUTPUT