summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFilip Lajszczak <filip@lajszczak.dev>2023-11-11 22:21:55 +0000
committerDavid Thompson <dthompson2@worcester.edu>2023-11-11 20:10:48 -0500
commitf93126a099712286b760900c1dc543b54a5ebf1c (patch)
tree17dc85fc14377e4861e9c722dff26bcd0551f672 /Makefile.am
parent544d95417e350d5bf8fa5ab402bec48e152d6228 (diff)
Add Sourcehut publisher.
* haunt/publisher/sourcehut.scm: New file. * configure.ac: Check for presence of hut and tar. * Makefile.am: Conditionally add sourcehut publisher to build. * guix.scm: Add hut and tar inputs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b12737..7a6583e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,9 +97,18 @@ SOURCES += haunt/publisher/rsync.scm
endif
+if HAVE_HUT
+if HAVE_TAR
+
+SOURCES += haunt/publisher/sourcehut.scm
+
+endif
+endif
+
TESTS = \
tests/helper.scm \
tests/post.scm \
+ tests/publisher-hut.scm \
tests/utils.scm
TEST_EXTENSIONS = .scm