summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2017-01-23 19:45:05 -0500
committerDavid Thompson <dthompson2@worcester.edu>2017-01-23 19:45:05 -0500
commit6568361bd3f33c43879d57047437a34083b9c12d (patch)
tree36037254043ee81abd8aa51781a333fa96c38147 /Makefile.am
parent970dc045394a3c37c657d56f6d05c9d36998c9a1 (diff)
Add 'make publish' target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5de973..59774ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,3 +103,8 @@ SUBDIRS = \
CLEANFILES = \
$(GOBJECTS) \
$(TESTS:tests/%.scm=%.log)
+
+publish: distcheck
+ gpg --sign --armor --yes haunt-$(VERSION).tar.gz && \
+ scp haunt-$(VERSION).tar.gz haunt-$(VERSION).tar.gz.asc \
+ blog@dthompson.us:/var/www/files/haunt/