summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-02-15 19:56:41 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-02-15 19:56:41 -0500
commit5373877f989689209616109b13fd471b2d093b5f (patch)
tree84ca709ff8ffbb9b9856af010e330fbc82ed9324 /Makefile.am
parent8b1adf1dcda1575a8c25710e8fbad1958785813b (diff)
build: Allow building with Guile 2.2.
* Makefile.am (moddir, goddir): Remove hardcoded "2.0". * configure.ac: Check to 2.2 as well.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d49aba..6f65ddc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,8 @@ SUFFIXES = .scm .go
.scm.go:
$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
-moddir=$(prefix)/share/guile/site/2.0
-godir=$(libdir)/guile/2.0/ccache
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
bin_SCRIPTS = \
scripts/haunt