summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2022-07-09 09:00:26 -0400
committerDavid Thompson <dthompson2@worcester.edu>2022-07-09 09:00:26 -0400
commit3c3a5ca21345b8df791486027ee367130ed45374 (patch)
tree93983a085609d31c7ac4b2770d8d8191e6599208 /Makefile.am
parenta090d0a7c9168ca6292c6cdf1b8c27c5a067c085 (diff)
Factor watch implementations into their own modules.
This should also hopefully resolve some issues that Christine Lemmer-Webber reported with the old code when resolving all of those inotify bindings at runtime.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bddaa4..0df352d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,6 +58,7 @@ SOURCES = \
haunt/builder/rss.scm \
haunt/reader.scm \
haunt/reader/texinfo.scm \
+ haunt/watch/fallback.scm \
haunt/ui.scm \
haunt/ui/build.scm \
haunt/ui/serve.scm \
@@ -82,7 +83,9 @@ endif
if HAVE_INOTIFY
-SOURCES += haunt/inotify.scm
+SOURCES += \
+ haunt/inotify.scm \
+ haunt/watch/linux.scm
endif