summaryrefslogtreecommitdiff
path: root/pre-inst-env.in
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-08-30 09:11:14 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-08-30 10:50:02 -0400
commit12b93bd0d5ab6b66ba002af8b282d32c713254dd (patch)
treee8af92e1903bbd9f940ade04cc3f7c5ee028626b /pre-inst-env.in
parentbf483586a2304f8d60b077aee36370d2cb211da7 (diff)
Add basic autotools files.
* Makefile.am: New file. * autogen.sh: New file. * configure.ac: New file. * env.in: New file. * guile.am: New file. * pre-inst-env.in: New file. * .gitignore: Ignore auto-generated files.
Diffstat (limited to 'pre-inst-env.in')
-rw-r--r--pre-inst-env.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/pre-inst-env.in b/pre-inst-env.in
new file mode 100644
index 0000000..0c30967
--- /dev/null
+++ b/pre-inst-env.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+# guix-web - Web interface for GNU Guix
+# Copyright © 2014 David Thompson <davet@gnu.org>
+#
+# This program is free software: you can redistribute it and/or
+# modify it under the terms of the GNU Affero General Public License
+# as published by the Free Software Foundation, either version 3 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public
+# License along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+
+abs_top_srcdir="`cd "@abs_top_srcdir@" > /dev/null; pwd`"
+abs_top_builddir="`cd "@abs_top_builddir@" > /dev/null; pwd`"
+
+GUILE_LOAD_COMPILED_PATH="$abs_top_builddir${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_LOAD_COMPILED_PATH"
+GUILE_LOAD_PATH="$abs_top_builddir:$abs_top_srcdir${GUILE_LOAD_PATH:+:}:$GUILE_LOAD_PATH"
+export GUILE_LOAD_COMPILED_PATH GUILE_LOAD_PATH
+
+PATH="$abs_top_builddir/scripts:$PATH"
+export PATH
+
+exec "$@"