summaryrefslogtreecommitdiff
path: root/guix/web/config.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-01-31 20:54:35 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-01-31 20:54:35 -0500
commit74217b986ba5582c70ec84b94b3b972764b515b6 (patch)
treeb564ca79ed403e6ba9efbd677e481f0b05a1b79a /guix/web/config.scm
parent6d7586080110fbcb83f8ae5344d0545314d97ae6 (diff)
Move all modules into the 'guix web' namespace.
* guix-web/config.scm: Delete. * guix-web/controller.scm: Delete. * guix-web/package.scm: Delete. * guix-web/render.scm: Delete. * guix-web/server.scm: Delete. * guix-web/sxml.scm: Delete. * guix-web/util.scm: Delete. * guix-web/view/html.scm: Delete. * guix-web/view/json.scm: Delete. * guix/web/config.scm: New file. * guix/web/controller.scm: New file. * guix/web/package.scm: New file. * guix/web/render.scm: New file. * guix/web/server.scm: New file. * guix/web/sxml.scm: New file. * guix/web/util.scm: New file. * guix/web/view/html.scm: New file. * guix/web/view/json.scm: New file. * guix/scripts/web.scm: Tweak imports. * Makefile.am (SOURCES): Add new files and remove deleted ones.
Diffstat (limited to 'guix/web/config.scm')
-rw-r--r--guix/web/config.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/guix/web/config.scm b/guix/web/config.scm
new file mode 100644
index 0000000..2461cc9
--- /dev/null
+++ b/guix/web/config.scm
@@ -0,0 +1,26 @@
+;;; guix-web - Web interface for GNU Guix
+;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;;
+;;; This program is free software: you can redistribute it and/or
+;;; modify it under the terms of the GNU Affero General Public License
+;;; as published by the Free Software Foundation, either version 3 of
+;;; the License, or (at your option) any later version.
+;;;
+;;; This program is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; Affero General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU Affero General Public
+;;; License along with this program. If not, see
+;;; <http://www.gnu.org/licenses/>.
+
+(define-module (guix web config)
+ #:use-module (ice-9 match)
+ #:export (guix-web-asset-dir
+ guix-web-host
+ guix-web-port))
+
+(define guix-web-asset-dir (getcwd))
+(define guix-web-host "localhost")
+(define guix-web-port 8080)