summaryrefslogtreecommitdiff
path: root/guix/scripts
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-01-31 20:23:13 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-01-31 20:25:20 -0500
commit6d7586080110fbcb83f8ae5344d0545314d97ae6 (patch)
tree602166441e9f5cda320c0f9d2429d9509809e829 /guix/scripts
parent05664ee58924c39d641db83c63e44d4d7579b641 (diff)
Make guix-web a subcommand of guix.
* scripts/guix-web: Delete. * guix/scripts/web.scm: New file. * Makefile.am (SOURCES): Add it. (dev-server): Delete. * README.md (Use): Tweak usage instructions.
Diffstat (limited to 'guix/scripts')
-rw-r--r--guix/scripts/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/guix/scripts/web.scm b/guix/scripts/web.scm
new file mode 100644
index 0000000..da6270e
--- /dev/null
+++ b/guix/scripts/web.scm
@@ -0,0 +1,26 @@
+;;; guix-web - Web interface for GNU Guix
+;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This program is free software: you can redistribute it and/or
+;;; modify it under the terms of the GNU Affero General Public License
+;;; as published by the Free Software Foundation, either version 3 of
+;;; the License, or (at your option) any later version.
+;;;
+;;; This program is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; Affero General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU Affero General Public
+;;; License along with this program. If not, see
+;;; <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts web)
+ #:use-module (system repl server)
+ #:use-module (guix-web controller)
+ #:use-module (guix-web server)
+ #:export (guix-web))
+
+(define (guix-web . args)
+ (spawn-server (make-tcp-server-socket #:port 37146))
+ (start-guix-web (lambda (path) (controller path))))