summaryrefslogtreecommitdiff
path: root/guile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-08-30 09:11:14 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-08-30 10:50:02 -0400
commit12b93bd0d5ab6b66ba002af8b282d32c713254dd (patch)
treee8af92e1903bbd9f940ade04cc3f7c5ee028626b /guile.am
parentbf483586a2304f8d60b077aee36370d2cb211da7 (diff)
Add basic autotools files.
* Makefile.am: New file. * autogen.sh: New file. * configure.ac: New file. * env.in: New file. * guile.am: New file. * pre-inst-env.in: New file. * .gitignore: Ignore auto-generated files.
Diffstat (limited to 'guile.am')
-rw-r--r--guile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/guile.am b/guile.am
new file mode 100644
index 0000000..dc1e63f
--- /dev/null
+++ b/guile.am
@@ -0,0 +1,19 @@
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"