summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-08-30 09:11:14 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-08-30 10:50:02 -0400
commit12b93bd0d5ab6b66ba002af8b282d32c713254dd (patch)
treee8af92e1903bbd9f940ade04cc3f7c5ee028626b /Makefile.am
parentbf483586a2304f8d60b077aee36370d2cb211da7 (diff)
Add basic autotools files.
* Makefile.am: New file. * autogen.sh: New file. * configure.ac: New file. * env.in: New file. * guile.am: New file. * pre-inst-env.in: New file. * .gitignore: Ignore auto-generated files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..fe3d545
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+# guix-web - Web interface for GNU Guix
+# Copyright © 2014 David Thompson <davet@gnu.org>
+#
+# This program is free software: you can redistribute it and/or
+# modify it under the terms of the GNU Affero General Public License
+# as published by the Free Software Foundation, either version 3 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public
+# License along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+moddir=$(prefix)/share/guile/site/2.0
+godir=$(libdir)/guile/2.0/ccache
+
+SOURCES = \
+ guix-web/config.scm \
+ guix-web/controller.scm \
+ guix-web/package.scm \
+ guix-web/render.scm \
+ guix-web/server.scm \
+ guix-web/util.scm \
+ guix-web/view.scm
+
+EXTRA_DIST += env.in