summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-10-11 22:27:39 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-10-11 22:27:39 -0400
commitcdf9043e4b1fed50f59cf9b0044d7ab57b19783a (patch)
tree78441a6709676470d40200fdc03ebaf84ba85262
parentad3479304e95ff12c3356bc5248382511b358545 (diff)
Makefile: Add 'dev-server' target.
* Makefile.am (dev-server): New target. * README.md ('Use'): Document it.
-rw-r--r--Makefile.am3
-rw-r--r--README.md4
2 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fe3d545..74b731a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,3 +30,6 @@ SOURCES = \
guix-web/view.scm
EXTRA_DIST += env.in
+
+dev-server:
+ ./pre-inst-env scripts/guix-web
diff --git a/README.md b/README.md
index f97db50..bf1df0f 100644
--- a/README.md
+++ b/README.md
@@ -26,8 +26,8 @@ Wishlist
Use
---
-Simply run `./pre-inst-env guix-web` and visit `localhost:8080` in
-your web browser.
+To run guix-web from the root of the source tree, simply run `make
+dev-server` and visit `localhost:8080` in your web browser.
Dependencies
------------