summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-01-01 16:14:44 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-01-01 16:14:44 -0500
commit4ba7f87e455c53ad06b6591559465d4099593a1d (patch)
tree7e6e3b885e33fb3f873275fbbdb71c429ed3f552 /Makefile.am
parent2f64307dce77ce372afa80d04432749cc75a97d8 (diff)
build: Add 'publish' make target.
No more remembering how I sign and upload things. ;)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 594cbf9..d273093 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,3 +79,10 @@ EXTRA_DIST += \
guix.scm \
examples/hello.scm \
examples/hello.bmp
+
+publish: dist
+ gpg2 --sign --armor --yes guile-sdl2-$(VERSION).tar.gz && \
+ scp guile-sdl2-$(VERSION).tar.gz guile-sdl2-$(VERSION).tar.gz.asc \
+ blog@dthompson.us:/var/www/files/guile-sdl2/
+
+.PHONY: publish