summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c10d13..806157f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,6 +93,13 @@ SOURCES = \
chickadee/scripting.scm \
chickadee.scm
+TESTS = \
+ tests/math/vector.scm
+
+TEST_EXTENSIONS = .scm
+SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
EXTRA_DIST += \
COPYING \
run-example \
@@ -121,7 +128,8 @@ EXTRA_DIST += \
examples/images/serene-village.png \
examples/maps/example.tmx \
examples/maps/serene-village.tsx \
- examples/models/suzanne.obj
+ examples/models/suzanne.obj \
+ tests/utils.scm
dist_pkgdata_DATA = \
data/AUTHORS \