summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2018-12-13 17:52:15 -0500
committerDavid Thompson <dthompson2@worcester.edu>2018-12-13 20:53:29 -0500
commitfe89f847503573378180ddbe5e6badec18093c37 (patch)
tree33ef04eefee4b6c9da2dc3cb72629e9963dd7dad /Makefile.am
parentda895821c9aa1f8ec63e2eb7e8d317040d9989d7 (diff)
render: font: Include a default font for convenience.
* data/fonts/good-neighbors.fnt: New file. * data/fonts/good-neighbors.png: New file. * data/CREDITS: New file. * examples/fonts/AUTHORS: Delete. * examples/fonts/good_neighbors_starling.png: Delete. * examples/fonts/good_neighbors_starling.xml: Delete. * Makefile.am (dist_pkgdata_DATA, fontsdir, dist_fonts_DATA): New variables. (EXTRA_DIST): Remove examples/fonts files. * chickadee/render/font.scm (draw-text): Make font an optional keyword argument. * doc/api.texi (Fonts): Document it. * examples/grid.scm: Update to use new draw-text API. * examples/nine-patch.scm: Ditto. * examples/text.scm: Ditto. squash! render: font: Include a default font for convenience.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2933194..3bb8c2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,11 +90,16 @@ EXTRA_DIST += \
examples/images/chickadee.png \
examples/images/dialog-box.png \
examples/images/tiles.png \
- examples/fonts/AUTHORS \
- examples/fonts/good_neighbors_starling.png \
- examples/fonts/good_neighbors_starling.xml \
examples/maps/example.tmx
+dist_pkgdata_DATA = \
+ data/CREDITS
+
+fontsdir = $(pkgdatadir)/fonts
+dist_fonts_DATA = \
+ data/fonts/good-neighbors.fnt \
+ data/fonts/good-neighbors.png
+
shadersdir = $(pkgdatadir)/shaders
dist_shaders_DATA = \
data/shaders/pbr/pbr-vert.glsl \