summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2017-01-04 22:16:26 -0500
committerDavid Thompson <dthompson2@worcester.edu>2017-01-04 22:16:26 -0500
commit98dc87a054c1108bd5f4bb093024d962ce0c8ce2 (patch)
tree9fa25dca82134bcdbe8693bfd5b212ce3b3880f8 /Makefile.am
First commit!
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..780a085
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,64 @@
+## Chickadee Game Toolkit
+## Copyright © 2016 David Thompson <davet@gnu.org>
+##
+## Chickadee is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published
+## by the Free Software Foundation, either version 3 of the License,
+## or (at your option) any later version.
+##
+## Chickadee is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see
+## <http://www.gnu.org/licenses/>.
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
+
+SOURCES = \
+ chickadee/config.scm \
+ chickadee/input/controller.scm \
+ chickadee/math.scm \
+ chickadee/math/vector.scm \
+ chickadee/math/matrix.scm \
+ chickadee/color.scm \
+ chickadee/render/gl.scm \
+ chickadee/render/gpu.scm \
+ chickadee/render/blend.scm \
+ chickadee/render/texture.scm \
+ chickadee/render/shader.scm \
+ chickadee/render/vertex-buffer.scm \
+ chickadee/render/shapes.scm \
+ chickadee/render/sprite.scm \
+ chickadee/render.scm \
+ chickadee/window.scm \
+ chickadee.scm
+
+info_TEXINFOS = doc/chickadee.texi
+
+chickadee_TEXINFOS = \
+ doc/fdl.texi \
+ doc/chickadee.texi