summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2021-10-02 07:57:08 -0400
committerDavid Thompson <dthompson2@worcester.edu>2021-10-02 07:57:08 -0400
commit35e38f323138d6a9e7a9b118d18cd26373cac269 (patch)
treecf97ade5303b02570ee20a3cc23fbc13c299fefe /Makefile.am
parent3ef47062ce802fb6c970ba031769bcf64d0043aa (diff)
Add tests for array lists, heaps, and queues.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b439cb5..45ef197 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,7 +101,10 @@ SOURCES = \
TESTS = \
tests/math/vector.scm \
- tests/data/quadtree.scm
+ tests/data/array-list.scm \
+ tests/data/heap.scm \
+ tests/data/quadtree.scm \
+ tests/data/queue.scm
TEST_EXTENSIONS = .scm
SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)