summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2021-10-06 17:11:01 -0400
committerDavid Thompson <dthompson2@worcester.edu>2021-10-06 17:11:01 -0400
commit15d838868b6dd7993d3f04c0a22bd9addaf731af (patch)
treef06bcbcfaa35eea0bda1a026c5d1e51bcfdb4baa /Makefile.am
parent03cb76faf452dcf30fe86d6522c1de88ba2fa923 (diff)
Collapse test hierarchy into a single directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 45ef197..b5e77f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -100,11 +100,11 @@ SOURCES = \
chickadee/cli/bundle.scm
TESTS = \
- tests/math/vector.scm \
- tests/data/array-list.scm \
- tests/data/heap.scm \
- tests/data/quadtree.scm \
- tests/data/queue.scm
+ tests/vector.scm \
+ tests/array-list.scm \
+ tests/heap.scm \
+ tests/quadtree.scm \
+ tests/queue.scm
TEST_EXTENSIONS = .scm
SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
@@ -143,7 +143,11 @@ EXTRA_DIST += \
examples/models/Suzanne/Suzanne.gltf \
examples/models/Suzanne/Suzanne_BaseColor.png \
examples/models/Suzanne/Suzanne_MetallicRoughness.png \
- tests/utils.scm
+ tests/utils.scm \
+ $(TESTS)
+
+CLEANFILES += \
+ $(TESTS:tests/%.scm=%.log)
dist_pkgdata_DATA = \
data/AUTHORS \