summaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2022-10-22 20:42:54 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2022-10-22 20:55:46 -0400
commit18565edfb75218cee5ad67bd521d33ecc495b6a4 (patch)
tree93c812f97a7910119f13067efe984e4b9609dae5 /guix.scm
First commit!
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm180
1 files changed, 180 insertions, 0 deletions
diff --git a/guix.scm b/guix.scm
new file mode 100644
index 0000000..33438a1
--- /dev/null
+++ b/guix.scm
@@ -0,0 +1,180 @@
+;;; Catbird Game Engine
+;;; Copyright © 2022 David Thompson <davet@gnu.org>
+;;;
+;;; Catbird is free software: you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation, either version 3 of the License, or
+;;; (at your option) any later version.
+;;;
+;;; Catbird is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Catbird. If not, see <http://www.gnu.org/licenses/>.
+
+;;; Commentary:
+;;
+;; Development environment for GNU Guix.
+;;
+;; To setup a development environment and build, run:
+;;
+;; guix shell
+;; ./bootstrap
+;; ./configure
+;; make -j${nproc}
+;;
+;; To build the development snapshot, run:
+;;
+;; guix build -f guix.scm
+;;
+;; To install the development snapshot, run:
+;;
+;; guix install -f guix.scm
+;;
+;;; Code:
+(use-modules (ice-9 match)
+ (srfi srfi-1)
+ (guix build-system gnu)
+ (guix download)
+ (guix gexp)
+ (guix git-download)
+ ((guix licenses) #:prefix license:)
+ (guix packages)
+ (guix utils)
+ (gnu packages)
+ (gnu packages audio)
+ (gnu packages autotools)
+ (gnu packages fontutils)
+ (gnu packages gl)
+ (gnu packages guile)
+ (gnu packages image)
+ (gnu packages maths)
+ (gnu packages mp3)
+ (gnu packages pkg-config)
+ (gnu packages readline)
+ (gnu packages sdl)
+ (gnu packages texinfo)
+ (gnu packages xiph))
+
+(define target-guile guile-3.0-latest)
+
+(define guile3.0-opengl
+ (package
+ (inherit guile-opengl)
+ (inputs
+ (modify-inputs (package-inputs guile-opengl)
+ (replace "guile" target-guile)))
+ (native-inputs
+ (modify-inputs (package-native-inputs guile-opengl)
+ (append autoconf automake)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-opengl)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'patch-makefile)
+ (add-before 'bootstrap 'patch-configure.ac
+ (lambda _
+ ;; The Guile version check doesn't work for the 3.0
+ ;; pre-release, so just remove it.
+ (substitute* "configure.ac"
+ (("GUILE_PKG\\(\\[2.2 2.0\\]\\)") ""))
+ (substitute* "Makefile.am"
+ (("\\$\\(GUILE_EFFECTIVE_VERSION\\)") "3.0")
+ (("ccache") "site-ccache"))
+ #t))
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vfi")))))))))
+
+(define guile-sdl2
+ (let ((commit "e9a7f5e748719ce5b6ccd08ff91861b578034ea6"))
+ (package
+ (name "guile-sdl2")
+ (version (string-append "0.7.0-1." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.dthompson.us/guile-sdl2.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ay7mcar8zs0j5rihwlzi0l46vgg9i93piip4v8a3dzwjx3myr7v"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "sh" "bootstrap"))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list target-guile sdl2))
+ (synopsis "Guile bindings for SDL2")
+ (description "Guile-sdl2 provides pure Guile Scheme bindings to the
+SDL2 C shared library via the foreign function interface.")
+ (home-page "https://git.dthompson.us/guile-sdl2.git")
+ (license license:lgpl3+))))
+
+(define chickadee
+ (let ((commit "5edce04c698cd92149004ead1cad77c481c682e8"))
+ (package
+ (name "chickadee")
+ (version (string-append "0.8.0-1." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.dthompson.us/chickadee.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1hckx827aw3af8cbw1mfjy57wdssv1q3bs2hziymxddipwa0d425"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "sh" "bootstrap"))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list freetype
+ libjpeg-turbo
+ libpng
+ libvorbis
+ mpg123
+ openal
+ readline
+ target-guile))
+ (propagated-inputs (list guile3.0-opengl guile-sdl2))
+ (synopsis "Game development toolkit for Guile Scheme")
+ (description "Chickadee is a game development toolkit for Guile
+Scheme. It contains all of the basic components needed to develop
+2D/3D video games.")
+ (home-page "https://dthompson.us/projects/chickadee.html")
+ (license license:gpl3+))))
+
+(define %source-dir (dirname (current-filename)))
+
+(package
+ (name "catbird")
+ (version "0.1")
+ (source (local-file %source-dir
+ #:recursive? #t
+ #:select? (git-predicate %source-dir)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "sh" "bootstrap"))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list target-guile))
+ (propagated-inputs (list chickadee guile-sdl2))
+ (synopsis "Game engine for Scheme programmers")
+ (description "Catbird is a game engine written in Guile Scheme.")
+ (home-page "https://dthompson.us/projects/chickadee.html")
+ (license license:gpl3+))