summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2021-10-15 14:47:08 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2021-10-15 14:47:08 -0400
commita2b03f564d1eb66298c5502b07e36c67f856857e (patch)
treeeaf8c93129b3ebb4256542eb1339a28baf4a8ac5 /configure.ac
Add project skeleton.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..0c892e4
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,17 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(bonnie-bee, 0.1.0)
+AC_CONFIG_SRCDIR(bonnie-bee)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([3.0])
+GUILE_PROGS
+GUILE_MODULE_REQUIRED([starling node])
+
+AC_OUTPUT