summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2018-08-24 08:39:28 -0400
committerDavid Thompson <dthompson2@worcester.edu>2018-08-24 08:39:28 -0400
commit01c93a1ebe9e5648a73025d5356d9cee72c7464d (patch)
tree92e7a43c04c680e38fbbc0b918cdd7c28930b5a5 /configure.ac
First commit!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..96f7561
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(starling, 0.3.0)
+AC_CONFIG_SRCDIR(starling)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([2.2])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([chickadee])
+GUILE_MODULE_REQUIRED([sdl2])
+
+AC_OUTPUT