summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2021-03-18 21:27:13 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2021-03-19 09:43:57 -0400
commit2917dbf5e132c1196bfbda3508743884293a5775 (patch)
tree2e52c536e21a7d338c4d43a461e4e92107333e9f /Makefile.am
parent8518a790cb2a20a5512dc0f2b6af53bd0d625f41 (diff)
Add test-env script for wrapping test runs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 22e6d4d..4500ecd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,9 +30,8 @@ TESTS = \
tests/webvtt.scm
TEST_EXTENSIONS = .scm
-
-SCM_LOG_COMPILER = $(GUILE)
-AM_SCM_LOG_FLAGS = --no-auto-compile -L $(top_srcdir)
+SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile
CLEANFILES = \
$(GOBJECTS) \
@@ -42,7 +41,8 @@ EXTRA_DIST = \
$(SOURCES) \
$(TESTS) \
tests/utils.scm \
- pre-inst-env.in
+ pre-inst-env.in \
+ test-env.in
dist_bin_SCRIPTS = scripts/srt2vtt