summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-02-11 21:29:54 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-02-11 21:33:05 -0500
commitdc21596b5bcc06342e0a9c647a79de256ab5c56a (patch)
tree972d71a458dcdffe650fc3d03ac7145047a727cb /configure.ac
parent1a375482bf71287801fb4258c6387d92236b6fab (diff)
Remove GSL dependency.
* sly/config.scm.in (%libgslcblas): Delete. * sly/wrappers/gsl.scm: Delete. * Makefile.am (WRAPPER_SOURCES): Remove it. * configure.ac: Remove GSL configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index f053e73..ff0f6e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,29 +27,4 @@ GUILE_MODULE_REQUIRED([sdl2 mixer])
GUILE_MODULE_REQUIRED([sdl2 ttf])
GUILE_MODULE_REQUIRED([gl])
-LIBGSLCBLAS="libgslcblas"
-LIBGSLCBLAS_LIBDIR="no"
-LIBGSLCBLAS_PREFIX="no"
-
-AC_ARG_WITH([libgslcblas-prefix],
- [AS_HELP_STRING([--with-libgslcblas-prefix=DIR], [search for GSL CBLAS in DIR])],
- [case "$withval" in
- yes|no)
- ;;
- *)
- LIBGSLCBLAS="$withval/lib/libgslcblas"
- LIBGSLCBLAS_PREFIX="$withval"
- LIBGSLCBLAS_LIBDIR="$withval/lib"
- ;;
- esac])
-
-dnl Library name suitable for `dynamic-link'.
-AC_MSG_CHECKING([for libgslcblas shared library name])
-AC_MSG_RESULT([$LIBGSLCBLAS])
-AC_SUBST([LIBGSLCBLAS])
-AC_SUBST([LIBGSLCBLAS_PREFIX])
-AC_SUBST([LIBGSLCBLAS_LIBDIR])
-
-PKG_CHECK_MODULES([GSL], [gsl])
-
AC_OUTPUT