summaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorFilip Lajszczak <filip@lajszczak.dev>2023-11-11 22:21:55 +0000
committerDavid Thompson <dthompson2@worcester.edu>2023-11-11 20:10:48 -0500
commitf93126a099712286b760900c1dc543b54a5ebf1c (patch)
tree17dc85fc14377e4861e9c722dff26bcd0551f672 /guix.scm
parent544d95417e350d5bf8fa5ab402bec48e152d6228 (diff)
Add Sourcehut publisher.
* haunt/publisher/sourcehut.scm: New file. * configure.ac: Check for presence of hut and tar. * Makefile.am: Conditionally add sourcehut publisher to build. * guix.scm: Add hut and tar inputs.
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/guix.scm b/guix.scm
index 8685eb2..6ee9262 100644
--- a/guix.scm
+++ b/guix.scm
@@ -34,10 +34,12 @@
(guix build-system gnu)
(gnu packages)
(gnu packages autotools)
+ (gnu packages base)
(gnu packages guile)
(gnu packages guile-xyz)
(gnu packages pkg-config)
- (gnu packages texinfo))
+ (gnu packages texinfo)
+ (gnu packages version-control))
(package
(name "haunt")
@@ -50,7 +52,7 @@
(add-after 'unpack 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap")))))))
(native-inputs (list autoconf automake pkg-config texinfo))
- (inputs (list guile-3.0))
+ (inputs (list guile-3.0 hut tar))
(propagated-inputs (list guile-commonmark guile-reader))
(synopsis "Functional static site generator")
(description "Haunt is a static site generator written in Guile