summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilip Lajszczak <filip@lajszczak.dev>2023-11-11 22:21:55 +0000
committerDavid Thompson <dthompson2@worcester.edu>2023-11-11 20:10:48 -0500
commitf93126a099712286b760900c1dc543b54a5ebf1c (patch)
tree17dc85fc14377e4861e9c722dff26bcd0551f672 /configure.ac
parent544d95417e350d5bf8fa5ab402bec48e152d6228 (diff)
Add Sourcehut publisher.
* haunt/publisher/sourcehut.scm: New file. * configure.ac: Check for presence of hut and tar. * Makefile.am: Conditionally add sourcehut publisher to build. * guix.scm: Add hut and tar inputs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a1c4620..02c6c8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,4 +36,10 @@ AC_CHECK_FUNC([inotify_init], [AM_CONDITIONAL(HAVE_INOTIFY, true)], [AM_CONDITIO
AC_PATH_PROG([RSYNC], [rsync])
AM_CONDITIONAL([HAVE_RSYNC], [test "x$RSYNC" != "x"])
+AC_PATH_PROG([HUT], [hut])
+AM_CONDITIONAL([HAVE_HUT], [test "x$HUT" != "x"])
+
+AC_PATH_PROG([TAR], [tar])
+AM_CONDITIONAL([HAVE_TAR], [test "x$TAR" != "x"])
+
AC_OUTPUT