summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorErik Edrosa <erik.edrosa@gmail.com>2016-08-01 22:40:22 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-08-02 07:48:24 -0400
commita4d18c0c53263c2c25e60beeb84df62048e08953 (patch)
tree87982c23168b465a71eda62a59e5858df9ee0aa6 /Makefile.am
parentef02127d54fc1f83bc3fed151eba32d8037df5c8 (diff)
reader: Add commonmark support.
* haunt/reader/commonmark.scm: New file. * Makefile.am (SOURCES): Add it. * configure.ac: Check for guile-commonmark.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 06f2753..a5de973 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
## Haunt --- Static site generator for GNU Guile
## Copyright © 2015 David Thompson <davet@gnu.org>
## Copyright © 2015 Mathieu Lirzin <mthl@gnu.org>
+## Copyright © 2016 Erik Edrosa <erik.edrosa@gmail.com>
##
## This file is part of Haunt.
##
@@ -70,6 +71,13 @@ SOURCES += \
endif
+if HAVE_GUILE_COMMONMARK
+
+SOURCES += \
+ haunt/reader/commonmark.scm
+
+endif
+
TESTS = \
tests/post.scm \
tests/utils.scm