summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2023-11-11 20:18:08 -0500
committerDavid Thompson <dthompson2@worcester.edu>2023-11-11 20:18:08 -0500
commit3ef600e96ef1eeed4798ebf4ca0f914f30f827ee (patch)
treefdc56ec9f8d79c1580911bd22daed1c90e8dbd2c /Makefile.am
parentff50e8c698e1ec5b9007e3bc4308109a69af2b41 (diff)
Build all publishers, fallback to $PATH lookups as necessary.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 2 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a6583e..15cc34f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,6 +59,8 @@ SOURCES = \
haunt/builder/blog.scm \
haunt/builder/rss.scm \
haunt/reader/texinfo.scm \
+ haunt/publisher/rsync.scm \
+ haunt/publisher/sourcehut.scm \
haunt/watch/fallback.scm \
haunt/ui.scm \
haunt/ui/build.scm \
@@ -91,20 +93,6 @@ SOURCES += \
endif
-if HAVE_RSYNC
-
-SOURCES += haunt/publisher/rsync.scm
-
-endif
-
-if HAVE_HUT
-if HAVE_TAR
-
-SOURCES += haunt/publisher/sourcehut.scm
-
-endif
-endif
-
TESTS = \
tests/helper.scm \
tests/post.scm \