summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-01-04 20:02:16 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-01-04 20:02:16 -0500
commit1cd43ba9677a7e5e988a2aaeb944434debaaa58b (patch)
treee25f63774df74c73f611db3fd7f53ba24283d488 /Makefile.am
First commit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..bd0437d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,45 @@
+## Haunt --- Static site generator for GNU Guile
+## Copyright © 2015 David Thompson <davet@gnu.org>
+##
+## This file is part of Haunt.
+##
+## Haunt is free software; you can redistribute it and/or modify it
+## under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## Haunt is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with Haunt. If not, see <http://www.gnu.org/licenses/>.
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir=$(prefix)/share/guile/site/2.0
+godir=$(libdir)/guile/2.0/ccache
+
+SOURCES = \
+ haunt/ui.scm
+
+EXTRA_DIST += pre-inst-env.in