summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-12-09 08:45:02 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-09 08:45:02 -0500
commitd58d696dc071f67be51cf616ae21c71be47b3e0a (patch)
tree047ef864058c77c8cb8c09e22bb892c6e49a22e8 /Makefile.am
parent0d42d0d8085b4a387f2e81360ff4c0b6ad229229 (diff)
Autotoolify.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..92457bd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,59 @@
+# guile-websocket --- WebSocket client/server
+# Copyright © 2015 David Thompson <davet@gnu.org>
+#
+# This file is part of guile-websocket.
+#
+# Guile-websocket is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 3 of the
+# License, or (at your option) any later version.
+#
+# Guile-websocket is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with guile-websocket. If not, see
+# <http://www.gnu.org/licenses/>.
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir=$(prefix)/share/guile/site/2.0
+godir=$(libdir)/guile/2.0/ccache
+
+SOURCES = \
+ web/socket/base64.scm \
+ web/socket/sha-1.scm \
+ web/socket/frame.scm \
+ web/socket/server.scm
+
+TESTS = \
+ tests/frame.scm
+
+TEST_EXTENSIONS = .scm
+SCM_LOG_COMPILER = $(top_builddir)/pre-inst-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
+EXTRA_DIST += \
+ pre-inst-env.in \
+ README \
+ guix.scm