summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2019-09-17 19:52:30 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-03-18 08:40:35 +0100
commit23b1fff2d633acd49433ddcace1ee58f816ba886 (patch)
treeb48dd2698ff3292c3b319a877eb9820fcb45c0fd /Makefile.am
parent3cb08041ab29c379e4b54dc092818b0dbfa044da (diff)
build: Support cross building.
* configure.ac: Add AC_CANONICAL_HOST to get host. * Makefile.am (.scm.go): Set it as target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0924e72..a7d8efe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,7 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
- $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile --target="$(host)" $(GUILE_WARNINGS) -o "$@" "$<"
moddir=$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache