summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2020-10-04 20:40:31 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2020-10-04 20:40:31 -0400
commit1386cfb20db6259ed74f089f31109e88e21bb5b3 (patch)
treeb2d6c39ac1d349cfe487f4c622586b9742ed1bca /Makefile.am
parent372a9cef5823786843e3562b21f54d847a28778c (diff)
Add system module to fix circular reference.
It's very bad that the node-2d module was depending on the kernel module. If the kernel includes a module that includes node-2d, a circular reference occurs and things get very strange very fast. Lots of weird compilation errors and stuff.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bc2ff0d..503a280 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,7 @@ godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
SOURCES = \
starling/config.scm \
starling/inotify.scm \
+ starling/system.scm \
starling/asset.scm \
starling/node.scm \
starling/scene.scm \