summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-02-09 20:17:17 -0500
committerDavid Thompson <dthompson2@worcester.edu>2014-02-09 20:17:17 -0500
commit342fbcffc1b17f03ae4b9f7de3caccc5e45da0f1 (patch)
treea4fcf920e20b6e127b19bb4479cf4a311fff77c4 /examples/Makefile.am
parent0529df9a8021d09f592e0a6eef0c19e148c5336e (diff)
Add examples Makefile.
* Makefile.am (SUBDIRS): Add 'examples'. * configure.ac (AC_CONFIG_FILES): Add 'examples/Makefile'. * examples/Makefile.am: New file.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..ee458d0
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,27 @@
+AUTOMAKE_OPTIONS = gnu
+
+examplesdir = $(pkgdatadir)/examples
+examples_DATA = \
+ animation.scm \
+ coroutine.scm \
+ font.scm \
+ particles.scm \
+ shader.scm \
+ simple.scm \
+ tilemap.scm
+
+imagedir = $(pkgdatadir)/examples/images
+image_DATA = \
+ images/bullet.png \
+ images/p1_front.png \
+ images/princess.png \
+ images/stars.png \
+ images/tiles.png
+
+fontdir = $(pkgdatadir)/examples/fonts
+font_DATA = fonts/Boxy-Bold.ttf
+
+shaderdir = $(pkgdatadir)/examples/shaders
+shader_DATA = \
+ shaders/vertex-shader.glsl \
+ shaders/fragment-shader.glsl