summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-02-16 10:44:24 -0500
committerDavid Thompson <dthompson2@worcester.edu>2014-02-16 10:47:04 -0500
commitfc2584672c096ae63469cce9ede9abaa4a95ece7 (patch)
tree2de08e6fad5251720ff58abed145a8c83741c93d /configure.ac
parentfd04e2133e098359e439a087535ce287f7fcc639 (diff)
Rewrite font module.
FTGL has been dropped in favor of SDL_ttf. * 2d/font: Rewrite everything! * 2d/wrappers/ftgl.scm: Delete it. * configure.ac: Check for SDL_ttf. * data/Makefile.am (shaders_DATA): Add font shaders. * data/shaders/font-fragment.glsl: New shader. * data/shaders/font-vertex.glsl: New shader. * examples/font.scm: Rewrite font example. * examples/fonts/AUTHORS: Delete it. * examples/fonts/Boxy-Bold.ttf: Delete it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 93b3922..01f74b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,7 @@ AC_CONFIG_FILES([Makefile doc/Makefile examples/Makefile data/Makefile])
AC_CONFIG_FILES([env], [chmod +x env])
PKG_CHECK_MODULES([SDL], [sdl <= 1.3 sdl >= 1.2])
-PKG_CHECK_MODULES([FTGL], [ftgl >= 2.1])
+PKG_CHECK_MODULES([SDL_tff], [SDL_ttf >= 2.0])
# Why doesn't freeimage have a pkg-config file?
#PKG_CHECK_MODULES([freeimage], [freeimage >= 3.0])