summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-11-07 20:36:06 -0500
committerDavid Thompson <dthompson2@worcester.edu>2014-11-07 20:40:08 -0500
commiteaa2189f189eedce4c10fd0fe56af563ffc00cc5 (patch)
treeb53adfac52f8334e4a5270e6fc0c110fcbe60956 /configure.ac
parentdcebda9c82c71915ae353d7edd16dc1fac2bb57b (diff)
configure: Check for guile-sdl and guile-opengl.
* configure.ac: Check for (sdl sdl), (sdl mixer), (sdl ttf), and (gl) modules.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 414cbc4..e23db07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,10 +10,12 @@ AC_CONFIG_FILES([Makefile doc/Makefile examples/Makefile data/Makefile])
AC_CONFIG_FILES([env], [chmod +x env])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
-
-PKG_CHECK_MODULES([SDL], [sdl <= 1.3 sdl >= 1.2])
-PKG_CHECK_MODULES([SDL_tff], [SDL_ttf >= 2.0])
GUILE_PROGS([2.0.11])
+GUILE_MODULE_REQUIRED([sdl sdl])
+GUILE_MODULE_REQUIRED([sdl mixer])
+GUILE_MODULE_REQUIRED([sdl ttf])
+GUILE_MODULE_REQUIRED([gl])
+
PKG_CHECK_MODULES([GSL], [gsl])
# Why doesn't freeimage have a pkg-config file?
#PKG_CHECK_MODULES([freeimage], [freeimage >= 3.0])