summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2013-07-26 18:53:52 -0400
committerDavid Thompson <dthompson2@worcester.edu>2013-07-26 18:53:52 -0400
commit1162ae833973fa81f0599b93a944672feb1bb982 (patch)
tree8a378ed0651e9d080b06ea26fbc09964c40803f4 /configure.ac
parent4225309c7eaaa2314ead21e1e2cbe44c05e6334c (diff)
Add autotools files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..dbf869d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,23 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(guile-2d, 0.1.0)
+AC_CONFIG_SRCDIR(2d)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+GUILE_PROGS
+
+if $GUILE_TOOLS | grep -q compile; then
+ # everything cool
+ true
+else
+ AC_MSG_ERROR([Guile 2.0 required.])
+fi
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([env], [chmod +x env])
+
+PKG_CHECK_MODULES([SDL], [sdl <= 1.3 sdl >= 1.2])
+
+AC_OUTPUT