summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 02c6c8f..1ccbb7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,13 +33,10 @@ AM_CONDITIONAL([HAVE_GUILE_COMMONMARK], [test "x$have_guile_commonmark" = "xyes"
AC_CHECK_FUNC([inotify_init], [AM_CONDITIONAL(HAVE_INOTIFY, true)], [AM_CONDITIONAL(HAVE_INOTIFY, false)])
-AC_PATH_PROG([RSYNC], [rsync])
-AM_CONDITIONAL([HAVE_RSYNC], [test "x$RSYNC" != "x"])
-
-AC_PATH_PROG([HUT], [hut])
-AM_CONDITIONAL([HAVE_HUT], [test "x$HUT" != "x"])
-
-AC_PATH_PROG([TAR], [tar])
-AM_CONDITIONAL([HAVE_TAR], [test "x$TAR" != "x"])
+dnl Attempt to find these programs, but if they're not found just
+dnl default to searching for them on $PATH at runtime.
+AC_PATH_PROG([RSYNC], [rsync], [rsync])
+AC_PATH_PROG([HUT], [hut], [hut])
+AC_PATH_PROG([TAR], [tar], [tar])
AC_OUTPUT