summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b12737..7a6583e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,9 +97,18 @@ SOURCES += haunt/publisher/rsync.scm
endif
+if HAVE_HUT
+if HAVE_TAR
+
+SOURCES += haunt/publisher/sourcehut.scm
+
+endif
+endif
+
TESTS = \
tests/helper.scm \
tests/post.scm \
+ tests/publisher-hut.scm \
tests/utils.scm
TEST_EXTENSIONS = .scm