summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0df352d..1b12737 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,17 +50,19 @@ SOURCES = \
haunt/page.scm \
haunt/asset.scm \
haunt/artifact.scm \
+ haunt/reader.scm \
+ haunt/publisher.scm \
haunt/site.scm \
haunt/html.scm \
haunt/builder/assets.scm \
haunt/builder/atom.scm \
haunt/builder/blog.scm \
haunt/builder/rss.scm \
- haunt/reader.scm \
haunt/reader/texinfo.scm \
haunt/watch/fallback.scm \
haunt/ui.scm \
haunt/ui/build.scm \
+ haunt/ui/publish.scm \
haunt/ui/serve.scm \
haunt/serve/mime-types.scm \
haunt/serve/web-server.scm
@@ -89,6 +91,12 @@ SOURCES += \
endif
+if HAVE_RSYNC
+
+SOURCES += haunt/publisher/rsync.scm
+
+endif
+
TESTS = \
tests/helper.scm \
tests/post.scm \