summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-01-04 22:23:47 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-01-04 22:49:59 -0500
commitf299cca70928759f04d44d81d6c2f0f6f9388e1b (patch)
tree69c4fed80cf71f0efaf79d7b4b6a25f448d016ba /Makefile.am
parent1cd43ba9677a7e5e988a2aaeb944434debaaa58b (diff)
Add serve command.
* haunt/config.scm: New file. * haunt/serve/mime-types.scm: New file. * haunt/serve/web-server.scm: New file. * haunt/ui/serve.scm: New file. * haunt/ui.scm (commands, program-name): New variables. (show-haunt-help): Display possible commands. (run-haunt-command): New procedure. (haunt-main): Run subcommands. * Makefile.am (SOURCES): Add files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bd0437d..65d1d81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,10 @@ moddir=$(prefix)/share/guile/site/2.0
godir=$(libdir)/guile/2.0/ccache
SOURCES = \
- haunt/ui.scm
+ haunt/config.scm \
+ haunt/ui.scm \
+ haunt/ui/serve.scm \
+ haunt/serve/mime-types.scm \
+ haunt/serve/web-server.scm
EXTRA_DIST += pre-inst-env.in