summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-10-14 10:44:00 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-10-14 10:50:03 -0400
commit397bc485d4985b284c3302027c2d9e82353162b7 (patch)
treeed97cc48309d6ecaf93230e22791da49c250c2fd /Makefile.am
parent32883938eb2faa135f268cfba851c6c6e3e6e478 (diff)
utils: Clean up and add tests.
* haunt/utils.scm (flat-map, string-split-at): Add docstring. (file-name-components): Adjust slightly to handle "/". (join-file-name-components): Use prefix string join grammar. (absolute-file-name): Add docstring. * test-env.in: New file. * tests/utils.scm: New file. * Makefile.am (TESTS, TEST_EXTENSIONS, SCM_LOG_COMPILER, AM_SCM_LOG_FLAGS): New variables. * configure.ac: Add test-env pre-processed file. * build-aux/test-driver: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 541d17f..3ddb01f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,13 @@ SOURCES += \
endif
+TESTS = \
+ tests/utils.scm
+
+TEST_EXTENSIONS = .scm
+SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
EXTRA_DIST += \
pre-inst-env.in \
README.md \