summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2024-10-02 21:22:19 -0400
committerDavid Thompson <dthompson2@worcester.edu>2024-10-03 07:12:23 -0400
commit567863b2398b6832f686b258709396572af0e980 (patch)
tree9876b28945a793fc6fedbd7f9804a0d7e159a47c /configure.ac
First commit!main
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..cb3407b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,42 @@
+# -*- Autoconf -*-
+#
+# guile-sdl3 -- Scheme bindings for SDL3
+# Copyright © 2024 David Thompson <dthompson2@worcester.edu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AC_INIT(guile-sdl3, 0.1.0)
+AC_CONFIG_SRCDIR(sdl3)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile sdl3/config.scm])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([3.0])
+GUILE_PROGS
+
+# Core SDL3
+dnl PKG_CHECK_MODULES([SDL3], [sdl3])
+dnl PKG_CHECK_VAR([SDL3_LIBDIR], [sdl3], [libdir])
+dnl AC_MSG_CHECKING([SDL3 library path])
+dnl AS_IF([test "x$SDL3_LIBDIR" = "x"], [
+dnl AC_MSG_FAILURE([unable to find SDL3 library directory])
+dnl ], [
+dnl AC_MSG_RESULT([$SDL3_LIBDIR])
+dnl ])
+dnl AC_SUBST([SDL3_LIBDIR])
+
+AC_OUTPUT